Thursday, 24 September 2009

Boarding School

I had advice (again) from Nophead (again) to forego the desoldering braid for removal of the dead chip on the first stepper motor driver board, and to cut the legs off as high, i.e. as close to the chip body, as possible. This I did - with the end legs, anyway, but I couldn't find anything fine enough to fit between and cut the other legs. After considering what was available that would definitely do the job with limited manoeuvre room, I decided to buy a chip-leg-cutter. You never know, I may need it in future.
This did the job well. When I lifted the broken chip off the board, a portion of the green board coating came away with it, exposing the copper underneath. The patch didn't extend to any of the pads. Carefully, I coated this with a thin protective layer of Araldite.
This was ancient - I got it in 1991, when I worked for the company! The lids were pretty stuck on, so that trying to unscrew them from the tubes resulted in highly twisted tubes, but putting some grip onto the lids worked. It is good to have some glue you know is still going to work years after first being opened.

Nophead's advice to brush the cut chip legs away with the soldering iron tip worked a treat. Each leg came away easily, and I wiped it from the iron. I used the flat tip to flatten the remaining solder on each pad, and put a thin line of paste along the row of pads on each side before soldering the new chip in place. The right way round!

I checked for bridges, and there were only bridges across legs that are connected with the trace anyway, so I didn't remove those bridges. I checked that there was continuity where there should be, and a lack of continuity where there should be, comparing with the working board. I checked the resistors, and they were all fine, too.

So I plugged in. Oops, no power LED and a very slight smoky smell. I switched straight off.
I took the power LED off, and checked it. Using my new flux pen to wet the component side of the desoldering braid, I was able to remove the solder quite easily. The LED had been fitted the right way around, and it still worked, so I soldered it back on. Hmm.

Since then, I have spent 2 days checking, rechecking and generally scratching my head. I checked all the vias going from top to bottom and did notice a couple without shiny metal rings like the working board has. At the stage I noticed, I didn't know what "vias" in electronics were!
I inserted the probe from my multimeter into the tops of the holes, and turned it around a few times. A thin green film came off, revealing shiny metal once more. I checked there was continuity between the top and bottom, and made sure there was for all such vias.

I checked the resistance for all the resistors, and they were all as rated. The only ones I couldn't check were the 0.25 ohm ones because my meter only went down as low as 200 ohm on its lowest setting.

At this stage, still scratching my head, I posted for more advice on the forum, specifically if the voltage regulator could be checked, and how.

I talked to my brother, who works in electronics, as he happened to 'phone, and he advised that I should check anywhere that a trace has been placed between the pads for a surface-mount component, because there may be a short here. I knew there were a couple of these on the boards, so I checked these, too. No problems found. He also suggested checking every pin, on the headers having 2 rows, against its neighbours. So I did that. No different from the working board. He also recommended connecting the power supply via a 12V bulb rated for 5 or 6 W to the board. If the board were shorted, the bulb would light more brightly compared with doing the same thing on the working board. I put this off because I couldn't locate a suitable bulb or pair of bulbs.

The advice from Nophead was simply to connect 12V power to the regulator and check that 5V came out.
Referring to this website, the power supplied to a 7805 regulator need only be 7V or more; a-ha, say a 9V battery, then, since I didn't want to connect the whole circuit again.
I roped in assistance, and connected wires to a PP3 battery with the ol' trusty Blu-Tack and held the +ve end against the reglator pin next to the "rrrf" text on the board, with the -ve end against the flat plate of the regulator, whilst my assistant measured the voltage off the pin next to the "make" text against the ground pin on the Molex-style connector. Oh. No voltage output. That would be the problem, then. No wonder the power LED didn't light, as it wasn't getting any power at all, it was all just going straight to ground!
That means the rest of the circuit hasn't been tested under voltage since the chip blew!

So for my next order, a new 7805DT voltage regulator..... And I said I might need the chip-leg cutter again, looks like it was sooner than I expected/hoped!

Nophead also explained that I could check the 0.25 ohm resistors by reading the resistance on the meter with the probes touched together, and subtracting that reading from the one I get on the low-value resistor. I'm going to try that next.

In the last 3 days, I have learnt a huge amount about checking boards.
I shall update the project costs soon.
.

3 comments:

  1. This is really great. I had nearly the same experience putting together the gen 1 boards for my strap. I never learned so much in my life in such a short amount of time as I did in trouble-shooting those boards.

    You have a fantastic blog. Keep up the good work and soon you'll have a working RepStrap!

    Demented

    ReplyDelete
  2. Demented,
    yes, my brother commented that it's only when things go wrong you really learn much! It wasn't a consolation at the time, though.
    Thank you for your kind comment about my blog - it's good to know it is appreciated.

    ReplyDelete
  3. Nice blog dear I like the way as you present your view among the all visitors. I would like to join you again on this blog it’s a very nice visit on this blog. It’s very attractive and effective for visitors. soldering fluxes manufacturer in Delhi, soldering wire manufacturers in Delhi

    ReplyDelete