Monday, 28 September 2009

Boarding school, term 3. Muddling through the end of year tests....

Hoorah! Hooray! Yippee! Wonderful! Marvellous! Brilliant! Fantastic! (Can you tell I'm happy?)

After a whole week of head-scratching, web browsing, and advice from my brother, my partner and Nophead, I have finally FIXED my bad stepper motor driver board. Unfortunately, this was the board with near-perfect soldering, of which I was very proud. Now it looks a mess! Anyway, here is the proof it works:

OK, it's not pretty.

The voltage regulator had been tested whilst still fixed to the board (but only by its ground pad). The regulator was definitely faulty. Unfortunately, once I'd removed that, everything else in the 5V path gave readings of zero ohm when tested on a 20 k ohm setting on the multimeter with the +ve probe on the path and the -ve probe on the ground pin of the Molex-style connector. This meant there was a short to ground somewhere, still.

The first thing I checked was the power-indicating LED, as this was what I had replaced twice, once because the first one was dead (although it turned out that that was incidental to the board not working), and once because I checked it for correct orientation when the board still didn't work. The result was that this part of the circuit certainly didn't look tidy, and was a cause for suspicion. I cleaned it very carefully and checked the gap between it and its protective resistor, but it looked separated. I wondered if I had damaged the pad on the board, but without disconnecting it from the circuit there was no way to check.

Next candidate was the damaged track alongside the regulator's space. I decided to cut the track close by the 5V pin' pad,so I scraped off the protective Araldite I had applied, and scraped back to the copper track. Then I very carefully cut the track, and made sure there was no continuity across the cut. Now, using the diode setting on the multimeter, I could light the power LED, so that side of the circuit was sound.
I cut the track in a similar way towards the rear of the regulator's space. Checking on resistance setting 20 k ohm again, the part of the track alongside the regulator gave reading of 1 against ground, meaning no connection to ground, ie no short there.
O.K., they were my top candidates! And they were fine. And I now had 2 unnecessary cuts in my track!

Oh well, nothing ventured, nothing gained.....
Following the track, it goes from the regulator to the electrolytic capacitor from where it splits, with part then heading to the 100 nF ceramic capacitor and to the second RJ45 socket, and the rest going down a "via" under the electrolytic capacitor and off to various other parts of the board.
In order to test this, I cut the track in a clear section underneath the board. Testing the chip end of the circuit to ground, the meter gave 1.
Ah-ha, now the problem is narrowed down to 2 capacitors, the "via" or the RJ45 socket.

The RJ45 socket seemed unlikely to have a problem, and ditto the large capacitor. Having plenty of spare 100 nF ceramic capacitors, thanks to supplies from Nophead after I cracked (a different) one on this board right at the start, I decided to simply swap it.
Some little desoldering and resoldering later, and voila! we have readings of 1 from everywhere on the 5V path to ground. So the problem WAS the capacitor.

Now my problem was the breaks I'd deliberately put in the track....
First I used the conductive pen to fill in the gap in the track on the underside of the board. It takes 10 minutes to get conductivity through the "ink", and testing afterwards showed I had good conductivity between the copper ends.
Unfortunately, when I tried this on the top of the board, I found that I also had re-shorting to ground! Obviously the cuts on the upper side of the board reached the ground connection in the board. So, using a trusty cocktail stick (which should also be added to the parts requirements!) I could paste Araldite (ditto) into the cuts in the copper track, but while that dried, I used the conductive pen to rejoin the breaks going around the cut section. If the conductive pen only works temporarily, I shall solder wires between the track breaks.

Then I soldered a new voltage regulator in place, with the help of Blu-Tack, again. Unfortunately, I knocked the electrolytic capacitor loose, causing more burning plastic due to access issues with my soldering iron as I fixed it back on. I tested it, and the voltage regulator, and then resoldered the first (removed) RJ45 socket. I tested everything exhaustively.

And now we have Blackpool at Christmas! (For those non-UKers, that means all the lights came on.)

My partner thought the board was a gonner. I thought if it didn't work anyway, there was nothing to lose by trying to resuscitate it, and it was going to take another 3 weeks to order a fresh board from the States anyway. And it works.



  1. Awesome work Hazel!

    I'm glad you got it working... and now you know enough to build everything else!


  2. I wouldn't call it awesome - if I hadn't got it so wrong to start with, then....
    Thank you anyway!

  3. I just realized you have fixed your broken stepper controller before. I have attempted to remove my blown up Alegro chip on my stepper board. (I have been busy playing with Bertha the CNC and methods for mounting Solar pannels thou.)
    And this weekend fitting shelves and other things for my 22y/o daughter.

  4. BodgeIt,
    I didn't know you'd blown the driver chip too. How did you do it?
    I removed th dead chip readily using Nophead's advice, and it is easy to replace - with a fine line of solder paste placed towards the ends of the pads, the new chip positioned carefully with minimal shifting about and a soldering iron touched and moved slowly across all the pins each side.
    Yes, firstly I had to replace the driver chip, then I had to track down collateral damage and fix that as well.
    I must say I AM relieved, and a little proud, that I managed to restore this board's full operation rather than having to buy a new one and start again.